Help with unknown error
Page 1 of 1

Author:  noobwannabe [ October 2nd, 2022, 10:30 am ]
Post subject:  Help with unknown error

Hello! I was recently trying my hand at adding cheatpacks to maps, and I succeeded a few times on some maps with no issues. Recently, I downloaded a map (Hongyeon RPG) and I was trying to add a cheatpack to it for someone in the map requests section, however after following the tutorials on the forums for adding the cheatpack, I was unable to host the map or test it out. Trying to host the map (after inserting NZCP) in WC3 Reforged instantly kicks me out of the lobby and I get an error message that has no text in it.

I was just wondering what might cause this error, or what this exactly means ! Thanks for all the help and advice!

Author:  noobwannabe [ October 3rd, 2022, 6:37 am ]
Post subject:  Re: Help with unknown error

Just following up with my own thread, I've figured out that the error is caused due to the map having S-Protect, I found the guide on the forum on how to remove SProtect and I tried to remove it, I was able to successfully replace all instances of "FF FF FF EE - - -" with "FF FF - - - " however, when I tried to replace the "EE EE -- 00 00 -- -- " pattern, it told me that it could not find any. After following the whole tutorial and completing it, it seems like Sprotect is still enabled on the map. Would love any advice or anything about this issue!

Author:  evil92 [ October 3rd, 2022, 10:05 am ]
Post subject:  Re: Help with unknown error

Hongyeon RPG does actually not have SProtect but rather is protected by PG3. If you download the map from the official cafe.naver site cafe.naver.com/hongyeonrpg and check out the header in a hex editor, you'll see that it says MPQ.PG3 at line 200. That's why it's not working out for you. Don't think there is a guide out there to fix PG3 corruption. I think there was one out for the original first version (PG), but it got updated over the years to PG2 and then PG3.

Author:  noobwannabe [ October 3rd, 2022, 10:54 am ]
Post subject:  Re: Help with unknown error

Oh, I see, thank you very much for your insight! it makes me happy to know that I have not been following the instructions wrong, its just something I haven't encountered yet.

Author:  NemesisQ15 [ October 4th, 2022, 7:44 pm ]
Post subject:  Re: Help with unknown error

Try to use deobfuscated CP

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group